Physical Reward Card Orders - Unable to Place Orders

Incident Report for BHN REWARDS

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 12:20 EDT

Investigating

We are currently experiencing an issue affecting physical reward card orders. Customers may be unable to place orders at this time. Our team is actively investigating and will provide updates as soon as possible.
Posted Apr 27, 2026 - 04:57 EDT
This incident affected: BHN Rewards Production (BHN Rewards Application - app.rybbon.net, BHN Rewards API).