Brand Outage: Multiple India Rewards

Incident Report for BHN REWARDS

Identified

Redemptions for all India brands are currently available, with the exception of Amazon. We will provide a further update once Amazon redemptions resume.
Posted Mar 19, 2026 - 06:39 EDT

Update

We are continuing to investigate this issue.
Posted Mar 12, 2026 - 02:17 EDT

Investigating

We are experiencing an increase in errors with multiple India brand redemptions. The issue is currently being investigated.
Posted Mar 10, 2026 - 02:15 EDT
This incident affects: BHN Rewards Production (BHN Rewards Application - app.rybbon.net).